update some vulnerable gems

parent 54a46474
Pipeline #47749 passed with stage
in 38 minutes and 53 seconds
require:
- rubocop-rails
AllCops:
TargetRubyVersion: 2.4.1
Exclude:
......
......@@ -67,6 +67,7 @@ group :development do
gem 'rcodetools', require: false
gem 'reek', require: false
gem 'rubocop', require: false
gem 'rubocop-rails', require: false
gem 'ruby-debug-ide', require: false
gem 'ruby-lint', require: false
gem 'scss_lint', require: false
......
......@@ -72,7 +72,7 @@ GEM
ast (2.4.0)
autocomplete_rails (0.3.1)
rails (>= 4.0, < 5.2)
autoprefixer-rails (9.1.4)
autoprefixer-rails (9.6.0)
execjs
awesome_print (1.8.0)
axiom-types (0.1.1)
......@@ -86,7 +86,7 @@ GEM
babel-transpiler (0.7.0)
babel-source (>= 4.0, < 6)
execjs (~> 2.0)
bcrypt (3.1.12)
bcrypt (3.1.13)
better_errors (2.4.0)
coderay (>= 1.0.0)
erubi (>= 1.0.0)
......@@ -154,7 +154,7 @@ GEM
colorize (0.8.1)
combine_pdf (1.0.10)
ruby-rc4 (>= 0.1.5)
concurrent-ruby (1.0.5)
concurrent-ruby (1.1.5)
countries (2.1.4)
i18n_data (~> 0.8.0)
money (~> 6.9)
......@@ -177,7 +177,7 @@ GEM
debug_inspector (0.0.3)
descendants_tracker (0.0.4)
thread_safe (~> 0.3, >= 0.3.1)
devise (4.4.3)
devise (4.6.2)
bcrypt (~> 3.0)
orm_adapter (~> 0.1)
railties (>= 4.1.0, < 6.0)
......@@ -193,7 +193,7 @@ GEM
dotenv (= 2.2.1)
railties (>= 3.2, < 5.2)
equalizer (0.0.11)
erubi (1.7.1)
erubi (1.8.0)
execjs (2.7.0)
factory_bot (4.10.0)
activesupport (>= 3.0.0)
......@@ -205,7 +205,7 @@ GEM
ruby_parser (>= 3.12.0)
ffaker (2.9.0)
ffi (1.9.25)
globalid (0.4.1)
globalid (0.4.2)
activesupport (>= 4.2.0)
hashery (2.1.2)
highline (2.0.0)
......@@ -219,7 +219,7 @@ GEM
ice_nine (0.11.2)
iniparse (1.4.4)
io-like (0.3.0)
jaro_winkler (1.5.1)
jaro_winkler (1.5.2)
jbuilder (2.7.0)
activesupport (>= 4.2.0)
multi_json (>= 1.2)
......@@ -247,21 +247,21 @@ GEM
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
ruby_dep (~> 1.2)
lodash-rails (4.17.10)
lodash-rails (4.17.11)
railties (>= 3.1)
loofah (2.2.2)
loofah (2.2.3)
crass (~> 1.0.2)
nokogiri (>= 1.5.9)
mail (2.7.0)
mini_mime (>= 0.1.1)
mdb (0.4.1)
method_source (0.8.2)
mime-types (3.1)
mime-types (3.2.2)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mimemagic (0.3.2)
mime-types-data (3.2019.0331)
mimemagic (0.3.3)
mini_mime (1.0.0)
mini_portile2 (2.3.0)
mini_portile2 (2.4.0)
minitest (5.10.3)
money (6.11.3)
i18n (>= 0.6.4, < 1.1)
......@@ -270,8 +270,8 @@ GEM
net-ssh (>= 2.6.5)
net-ssh (5.0.1)
nio4r (2.3.1)
nokogiri (1.8.2)
mini_portile2 (~> 2.3.0)
nokogiri (1.10.3)
mini_portile2 (~> 2.4.0)
orm_adapter (0.5.0)
overcommit (0.45.0)
childprocess (~> 0.6, >= 0.6.3)
......@@ -286,16 +286,16 @@ GEM
highline
therubyracer
unicorn-rails
paperclip (6.0.0)
paperclip (6.1.0)
activemodel (>= 4.2.0)
activesupport (>= 4.2.0)
mime-types
mimemagic (~> 0.3.0)
terrapin (~> 0.6.0)
parallel (1.12.1)
parallel (1.17.0)
paranoia (2.4.1)
activerecord (>= 4.0, < 5.3)
parser (2.5.1.0)
parser (2.6.3.0)
ast (~> 2.4.0)
path_expander (1.0.3)
pdf-reader (2.1.0)
......@@ -310,7 +310,6 @@ GEM
pundit (>= 1.0.0)
polyamorous (1.3.3)
activerecord (>= 3.0)
powerpack (0.1.2)
pry (0.10.4)
coderay (~> 1.1.0)
method_source (~> 0.8.1)
......@@ -325,8 +324,8 @@ GEM
puma (3.11.4)
pundit (1.1.0)
activesupport (>= 3.0.0)
rack (2.0.5)
rack-test (1.0.0)
rack (2.0.7)
rack-test (1.1.0)
rack (>= 1.0, < 3)
rails (5.1.4)
actioncable (= 5.1.4)
......@@ -356,10 +355,10 @@ GEM
thor (>= 0.18.1, < 2.0)
rainbow (3.0.0)
raindrops (0.19.0)
rake (12.3.1)
rake (12.3.2)
rb-fsevent (0.10.3)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
rb-inotify (0.10.0)
ffi (~> 1.0)
rcodetools (0.8.5.0)
redcarpet (3.4.0)
reek (5.3.1)
......@@ -369,38 +368,39 @@ GEM
psych (~> 3.1.0)
rainbow (>= 2.0, < 4.0)
ref (2.0.0)
responders (2.4.0)
actionpack (>= 4.2.0, < 5.3)
railties (>= 4.2.0, < 5.3)
responders (2.4.1)
actionpack (>= 4.2.0, < 6.0)
railties (>= 4.2.0, < 6.0)
roo (2.7.1)
nokogiri (~> 1)
rubyzip (~> 1.1, < 2.0.0)
rubocop (0.57.2)
rubocop (0.71.0)
jaro_winkler (~> 1.5.1)
parallel (~> 1.10)
parser (>= 2.5)
powerpack (~> 0.1)
parser (>= 2.6)
rainbow (>= 2.2.2, < 4.0)
ruby-progressbar (~> 1.7)
unicode-display_width (~> 1.0, >= 1.0.1)
unicode-display_width (>= 1.4.0, < 1.7)
rubocop-rails (2.0.0)
rack (>= 2.0)
rubocop (>= 0.70.0)
ruby-debug-ide (0.6.1)
rake (>= 0.8.1)
ruby-lint (2.3.1)
parser (~> 2.2)
slop (~> 3.4, >= 3.4.7)
ruby-progressbar (1.9.0)
ruby-progressbar (1.10.1)
ruby-rc4 (0.1.5)
ruby_dep (1.5.0)
ruby_parser (3.12.0)
sexp_processor (~> 4.9)
rubyzip (1.2.2)
sass (3.5.6)
sass (3.5.7)
sass-listen (~> 4.0.0)
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
sassc (1.11.4)
bundler
sassc (1.12.1)
ffi (~> 1.9.6)
sass (>= 3.3.0)
sassc-rails (1.3.0)
......@@ -454,7 +454,7 @@ GEM
therubyracer (0.12.3)
libv8 (~> 3.16.14.15)
ref
thor (0.20.0)
thor (0.20.3)
thread_safe (0.3.6)
tilt (2.0.8)
ttfunk (1.5.1)
......@@ -462,7 +462,7 @@ GEM
thread_safe (~> 0.1)
uglifier (4.1.11)
execjs (>= 0.3.0, < 3)
unicode-display_width (1.4.0)
unicode-display_width (1.6.0)
unicode_utils (1.4.0)
unicorn (5.4.0)
kgio (~> 2.6)
......@@ -475,14 +475,14 @@ GEM
coercible (~> 1.0)
descendants_tracker (~> 0.0, >= 0.0.3)
equalizer (~> 0.0, >= 0.0.9)
warden (1.2.7)
rack (>= 1.0)
warden (1.2.8)
rack (>= 2.0.6)
websocket-driver (0.6.5)
websocket-extensions (>= 0.1.0)
websocket-extensions (0.1.3)
wicked_pdf (1.1.0)
will-paginate-i18n (0.1.15)
will_paginate (3.1.6)
will_paginate (3.1.7)
wkhtmltopdf-binary (0.12.4)
xpath (3.1.0)
nokogiri (~> 1.8)
......@@ -549,6 +549,7 @@ DEPENDENCIES
reek
roo (~> 2.7.0)
rubocop
rubocop-rails
ruby-debug-ide
ruby-lint
rubyzip (>= 1.2.2)
......@@ -567,4 +568,4 @@ DEPENDENCIES
wkhtmltopdf-binary
BUNDLED WITH
1.17.1
1.17.3
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment