Commit f504e5a2 authored by Kaspar Vollenweider's avatar Kaspar Vollenweider

add some gems relevant for development ide suport to deveopment group in gemfile

parent 3b0267da
Pipeline #39397 canceled with stage
in 14 minutes and 4 seconds
......@@ -57,11 +57,18 @@ gem 'will_paginate'
gem 'wkhtmltopdf-binary'
group :development do
gem 'awesome_print'
gem 'awesome_print', require: false
gem 'debase', require: false
gem 'debride', require: false
gem 'fasterer', require: false
gem 'i18n_yaml_sorter'
gem 'letter_opener_web', '~> 1.0'
gem 'overcommit', require: false
gem 'rcodetools', require: false
gem 'reek', require: false
gem 'rubocop', require: false
gem 'ruby-debug-ide', require: false
gem 'ruby-lint', require: false
gem 'scss_lint', require: false
end
......
......@@ -75,6 +75,10 @@ GEM
autoprefixer-rails (9.1.4)
execjs
awesome_print (1.8.0)
axiom-types (0.1.1)
descendants_tracker (~> 0.0.4)
ice_nine (~> 0.11.0)
thread_safe (~> 0.3, >= 0.3.1)
axlsx_rails (0.5.1)
actionpack (>= 3.1)
axlsx (>= 2.0.1)
......@@ -135,7 +139,11 @@ GEM
nokogiri (~> 1.8)
climate_control (0.2.0)
cocoon (1.2.11)
codeclimate-engine-rb (0.4.1)
virtus (~> 1.0)
coderay (1.1.2)
coercible (1.0.0)
descendants_tracker (~> 0.0.1)
coffee-rails (4.2.2)
coffee-script (>= 2.2.0)
railties (>= 4.0.0)
......@@ -143,6 +151,7 @@ GEM
coffee-script-source
execjs
coffee-script-source (1.12.2)
colorize (0.8.1)
combine_pdf (1.0.10)
ruby-rc4 (>= 0.1.5)
concurrent-ruby (1.0.5)
......@@ -158,7 +167,16 @@ GEM
sort_alphabetical (~> 1.0)
crass (1.0.4)
database_cleaner (1.7.0)
debase (0.2.2)
debase-ruby_core_source (>= 0.10.2)
debase-ruby_core_source (0.10.4)
debride (1.8.1)
path_expander (~> 1.0)
ruby_parser (~> 3.6)
sexp_processor (~> 4.5)
debug_inspector (0.0.3)
descendants_tracker (0.0.4)
thread_safe (~> 0.3, >= 0.3.1)
devise (4.4.3)
bcrypt (~> 3.0)
orm_adapter (~> 0.1)
......@@ -174,6 +192,7 @@ GEM
dotenv-rails (2.2.1)
dotenv (= 2.2.1)
railties (>= 3.2, < 5.2)
equalizer (0.0.11)
erubi (1.7.1)
execjs (2.7.0)
factory_bot (4.10.0)
......@@ -181,6 +200,9 @@ GEM
factory_bot_rails (4.10.0)
factory_bot (~> 4.10.0)
railties (>= 3.0.0)
fasterer (0.4.2)
colorize (~> 0.7)
ruby_parser (>= 3.12.0)
ffaker (2.9.0)
ffi (1.9.25)
globalid (0.4.1)
......@@ -194,6 +216,7 @@ GEM
i18n_rails_helpers (2.0.1)
rails (> 3.0.0)
i18n_yaml_sorter (0.2.0)
ice_nine (0.11.2)
iniparse (1.4.4)
io-like (0.3.0)
jaro_winkler (1.5.1)
......@@ -210,6 +233,7 @@ GEM
railties (>= 3.2)
sprockets-rails
kgio (2.11.2)
kwalify (0.7.2)
launchy (2.4.3)
addressable (~> 2.3)
letter_opener (1.6.0)
......@@ -273,6 +297,7 @@ GEM
activerecord (>= 4.0, < 5.3)
parser (2.5.1.0)
ast (~> 2.4.0)
path_expander (1.0.3)
pdf-reader (2.1.0)
Ascii85 (~> 1.0.0)
afm (~> 0.2.1)
......@@ -295,6 +320,7 @@ GEM
pry (~> 0.10)
pry-rails (0.3.6)
pry (>= 0.10.4)
psych (3.1.0)
public_suffix (3.0.2)
puma (3.11.4)
pundit (1.1.0)
......@@ -334,7 +360,14 @@ GEM
rb-fsevent (0.10.3)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
rcodetools (0.8.5.0)
redcarpet (3.4.0)
reek (5.3.1)
codeclimate-engine-rb (~> 0.4.0)
kwalify (~> 0.7.0)
parser (>= 2.5.0.0, < 2.7, != 2.5.1.1)
psych (~> 3.1.0)
rainbow (>= 2.0, < 4.0)
ref (2.0.0)
responders (2.4.0)
actionpack (>= 4.2.0, < 5.3)
......@@ -350,9 +383,16 @@ GEM
rainbow (>= 2.2.2, < 4.0)
ruby-progressbar (~> 1.7)
unicode-display_width (~> 1.0, >= 1.0.1)
ruby-debug-ide (0.6.1)
rake (>= 0.8.1)
ruby-lint (2.3.1)
parser (~> 2.2)
slop (~> 3.4, >= 3.4.7)
ruby-progressbar (1.9.0)
ruby-rc4 (0.1.5)
ruby_dep (1.5.0)
ruby_parser (3.12.0)
sexp_processor (~> 4.9)
rubyzip (1.2.2)
sass (3.5.6)
sass-listen (~> 4.0.0)
......@@ -377,6 +417,7 @@ GEM
selenium-webdriver (3.12.0)
childprocess (~> 0.5)
rubyzip (~> 1.2)
sexp_processor (4.11.0)
simple_form (4.0.1)
actionpack (>= 5.0)
activemodel (>= 5.0)
......@@ -429,6 +470,11 @@ GEM
unicorn-rails (2.2.1)
rack
unicorn
virtus (1.0.5)
axiom-types (~> 0.1)
coercible (~> 1.0)
descendants_tracker (~> 0.0, >= 0.0.3)
equalizer (~> 0.0, >= 0.0.9)
warden (1.2.7)
rack (>= 1.0)
websocket-driver (0.6.5)
......@@ -464,10 +510,13 @@ DEPENDENCIES
countries_and_languages
country_select
database_cleaner
debase
debride
devise
devise-i18n
devise_invitable
factory_bot_rails
fasterer
ffaker
i18n_data
i18n_rails_helpers
......@@ -495,9 +544,13 @@ DEPENDENCIES
rails (~> 5.1)
rails-i18n
ransack!
rcodetools
redcarpet
reek
roo (~> 2.7.0)
rubocop
ruby-debug-ide
ruby-lint
rubyzip (>= 1.2.2)
sassc-rails
scss_lint
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment